117. Mikrotik Block IDM, Facebook and Youtube Download


You can contact me: plus.google.com/+PhallaCCMT; youtube.com/phallaccmt; facebook.com/Phalla.CCMT; twitter.com/PhallaCCMT and Phalla.CCMT@gmail.com

Script:

/ip firewall layer7-protocol
add name=L7-IDM regexp="get /.*(user-agent: mozilla/4.0|range: bytes=)"
add name=L7-Youtube regexp=youtube.com|googlevideo.com
add name=L7-Facebook regexp=fbcdn.net|facebook.com


/ip firewall filter
add action=drop chain=forward comment="Block IDM" connection-limit=2,32 \
    disabled=yes layer7-protocol=L7-IDM
add action=drop chain=forward comment="Block Youtube" connection-limit=2,32 \
    disabled=yes layer7-protocol=L7-Youtube
add action=drop chain=forward comment="Block Facebook" connection-limit=2,32 \
    disabled=yes layer7-protocol=L7-Facebook


Note:
If you want to block for specific user/ip, you can add that ip to filter rule.

Ex.
/ip firewall filter
add action=drop chain=forward comment="Block IDM" connection-limit=2,32 \
    disabled=yes layer7-protocol=IDM-Down src-address=192.168.88.103
add action=drop chain=forward comment="Block Youtube" connection-limit=2,32 \
    disabled=yes layer7-protocol=L7-Youtube src-address=192.168.88.103
add action=drop chain=forward comment="Block Facebook" connection-limit=2,32 \
    disabled=yes layer7-protocol=L7-Facebook src-address=192.168.88.103

Previous
Next Post »

10 comments

Write comments
Corner Blog
AUTHOR
August 21, 2017 at 9:49 PM delete

You can buy Youtube views which come from genuine Youtube accounts. In no time, your video will go viral and everyone will enjoy watching your fantastic video. viewgrip.net

Reply
avatar
September 6, 2017 at 10:50 AM delete

I still cannot block IDM Bro

Reply
avatar
kyaw zin
AUTHOR
October 17, 2017 at 1:16 PM delete

no it does not i think i can put static ip and write firewall

Reply
avatar
Unknown
AUTHOR
January 15, 2018 at 8:13 PM delete

Hope you are fine dear i want to block only videos not facebook and youtube only videos from IDM in your case all block facebook , youtube

Reply
avatar
Ayoola Noah
AUTHOR
March 12, 2018 at 4:22 PM delete

hi,
My name is Noah from nigeria, please I need your help on script to block IDM on mikrotik router for all browser i.e google chrome, mozilla e.t.c.
I will be grateful if my request can be granted, thanks.

regards,
Ayoola Noah.
ayoolanoah2004@gmail.com

Reply
avatar
eFeet eFeet
AUTHOR
January 16, 2019 at 11:07 AM delete

Hi, this rule regexp="get /.*(user-agent: mozilla/4.0|range: bytes=)", works very fine, but too block the Netflix App only in SmartTV's, this is a problem :S

Reply
avatar
S Jaden
AUTHOR
January 16, 2019 at 3:41 PM delete

An excellent way to make relevant friends on YouTube is to subscribe to the channels of users who create similar Videos that they make. usayoutube likes also here for buy..you must buy if you really want to promote your self.

Reply
avatar
Unknown
AUTHOR
March 3, 2019 at 9:10 PM delete

You know your projects stand out of the herd. There is something special about them. It seems to me all of them are really brilliant! Buy Facebook 5 Star Ratings Reviews

Reply
avatar
Unknown
AUTHOR
April 24, 2019 at 1:19 PM delete

I Coulden't block IDM Download, why???? Is there anybody to tell me , the solution

Reply
avatar