16. Mikrotik Priority Speedtest net, Priority User + Limit Download and Youtube




Here is a script:

/ip firewall filter
add action=add-dst-to-address-list address-list=Speedtest-List chain=forward \
    comment=Dst-Speedtest-List content=speedtest.net
add action=add-dst-to-address-list address-list=Youtube-List chain=forward \
    comment=Youtube content=googlevideo.com


/ip firewall mangle
add action=mark-connection chain=forward comment=Speedtest.Net \
    connection-state=new dst-address-list=Speedtest-List new-connection-mark=\
    Speedtest-conn
add action=mark-packet chain=forward connection-mark=Speedtest-conn \
    new-packet-mark=Speedtest-conn passthrough=no
add action=mark-connection chain=forward comment=Youtube.com \
    connection-state=new dst-address-list=Youtube-List new-connection-mark=\
    Youtube-conn
add action=mark-packet chain=forward connection-mark=Youtube-conn \
    new-packet-mark=Youtube-conn passthrough=no
add action=mark-connection chain=forward comment=Other connection-state=new \
    dst-address-list=!Speedtest-List new-connection-mark=Other-conn
add action=mark-packet chain=forward connection-mark=Other-conn \
    new-packet-mark=Other-conn passthrough=no
add action=mark-connection chain=forward comment=Phalla-LAN connection-state=\
    new new-connection-mark=Phalla-conn src-mac-address=00:50:56:C0:00:03
add action=mark-packet chain=forward connection-mark=Phalla-conn \
    new-packet-mark=Phalla-conn passthrough=no
add action=mark-connection chain=forward comment=Other-LAN connection-state=\
    new new-connection-mark=Other-LAN-conn src-mac-address=!00:50:56:C0:00:03
add action=mark-packet chain=forward connection-mark=Other-LAN-conn \
    new-packet-mark=Other-LAN-conn passthrough=no
add action=mark-connection chain=prerouting comment=Download \
    connection-bytes=262146-4294967295 in-interface=ether1 \
    new-connection-mark=Download-conn protocol=tcp src-port=21,80
add action=mark-packet chain=prerouting connection-mark=Download-conn \
    in-interface=ether1 new-packet-mark=Download-conn passthrough=no


/queue type
add kind=pcq name=PCQ pcq-classifier=dst-address pcq-dst-address6-mask=64 \
    pcq-rate=7M pcq-src-address6-mask=64
/queue tree
add max-limit=1M name=Local parent=global queue=default
add max-limit=1M name=Speedtest packet-mark=Speedtest-conn parent=Local \
    priority=1 queue=default
add max-limit=1M name=Other packet-mark=Other-conn parent=Local queue=default
add max-limit=1M name=Phalla packet-mark=Phalla-conn parent=Other priority=1 \
    queue=default
add max-limit=1M name=Other-LAN packet-mark=Other-LAN-conn parent=Other \
    queue=default
add max-limit=1M name=Download packet-mark=Download-conn parent=Other-LAN \
    queue=PCQ
add max-limit=1M name=Youtube packet-mark=Youtube-conn parent=Other-LAN \
    queue=PCQ


Previous
Next Post »

1 comments:

Write comments
January 21, 2017 at 4:20 PM delete

please enter the related post in your website templete

Reply
avatar