57. Mikrotik Separate Local(LAN) Speed with Internet Speed



We have two methods to Separate Local(LAN) Speed with Internet Speed. Below are the Script of each methods:

Method :

/ip firewall address-list
add address=10.0.0.0/8 list=IP-Local
add address=172.16.0.0/12 list=IP-Local
add address=192.168.0.0/16 list=IP-Local

/ip firewall mangle
add action=mark-connection chain=prerouting dst-address-list=IP-Local \
    new-connection-mark=Local-Conn
add action=mark-packet chain=postrouting connection-mark=Local-Conn \
    new-packet-mark=Local-Pack passthrough=no

/ip firewall nat
add action=masquerade chain=srcnat

/queue simple
add max-limit=5M/5M name=Local packet-marks=Local-Pack target=192.168.13.0/24
add max-limit=1M/1M name=Internet target=192.168.13.0/24



Method 2:

/ip firewall address-list
add address=10.0.0.0/8 list=IP-Local
add address=172.16.0.0/12 list=IP-Local
add address=192.168.0.0/16 list=IP-Local

/ip firewall mangle
add action=mark-connection chain=prerouting comment=\
    "Mark-connection All Traffic" new-connection-mark=All-Conn src-address=\
    192.168.13.0/24
add action=mark-connection chain=prerouting comment=\
    "Mark-connection Internet Traffic" connection-mark=All-Conn \
    dst-address-list=!IP-Local new-connection-mark=Internet-Conn src-address=\
    192.168.13.0/24
add action=mark-packet chain=prerouting comment=\
    "Mark-packet Internet Traffic" connection-mark=Internet-Conn \
    new-packet-mark=Internet-Traffic passthrough=no
add action=mark-packet chain=prerouting comment="Mark-packet Local Traffic" \
    new-packet-mark=Local-Traffic passthrough=no


/queue simple
add max-limit=3M/3M name=Internet-Speed packet-marks=Internet-Traffic target=\
    192.168.13.0/24
add max-limit=10M/10M name=Local-Speed packet-marks=Local-Traffic target=\
    192.168.13.0/24


You can contact me: plus.google.com/+PhallaCCMT; youtube.com/phallaccmt; facebook.com/Phalla.CCMT; twitter.com/PhallaCCMT and Phalla.CCMT@gmail.com
Previous
Next Post »

2 comments

Write comments
Unknown
AUTHOR
January 17, 2017 at 5:03 PM delete

well done!
It works like a charm!
Thanks

Reply
avatar