45. Mikrotik Auto Block|Drop Torrent, Utorrent and Bit torrent conntection


Here is a script:

/ip firewall layer7-protocol
add comment="Block Bit Torrent" name=layer7-bittorrent-exp regexp="^(\\x13bitt\
    orrent protocol|azver\\x01\$|get /scrape\\\?info_hash=get /announce\\\?inf\
    o_hash=|get /client/bitcomet/|GET /data\\\?fid=)|d1:ad2:id20:|\\x08'7P\\)[\
    RP]"

/ip firewall filter
add action=add-src-to-address-list address-list=bit-list \
    address-list-timeout=1m chain=forward disabled=yes dst-address-list=\
    !bit-unblock-list p2p=bit-torrent src-address-list=!bit-unblock-list
add action=add-src-to-address-list address-list=bit-list \
    address-list-timeout=1m chain=forward disabled=yes dst-address-list=\
    !bit-unblock-list layer7-protocol=layer7-bittorrent-exp src-address-list=\
    !bit-unblock-list src-address-type=local
add action=drop chain=forward disabled=yes dst-port=!80,443 protocol=tcp \
    src-address-list=bit-list
add action=drop chain=forward disabled=yes protocol=udp src-address-list=\
    bit-list

Previous
Next Post »

2 comments

Write comments
October 30, 2017 at 9:46 AM delete

p2p in no longer working and they omitted it in the new firmware of Mikrotik.

Reply
avatar
Userhopes
AUTHOR
July 17, 2019 at 6:13 PM delete

It would be ideal if you recollect that some private trackers will expect you to download your very own deluge again in the wake of transferring it, however except if they explicitly express this, there is no need.https://luckyshiner.com/rarbg-mirror-proxy-list/

Reply
avatar