40. Mikrotik Limit Speed Torrent, uTorrent and Bit torrent Download



Here is a script:

/ip firewall layer7-protocol
add name=L7-Torrent regexp="^(\\x13bittorrent protocol|azver\\x01\$|get /scrap\
    e\\\?info_hash=get /announce\\\?info_hash=|get /client/bitcomet/|GET /data\
    \\\?fid=)|d1:ad2:id20:|\\x08'7P\\)[RP]"

/queue tree
add limit-at=256k max-limit=256k name=Torrent-Download packet-mark=\
    Torrent-Conn parent=global priority=5 queue=default

/ip firewall filter
add action=add-src-to-address-list address-list=Torrent-Add \
    address-list-timeout=2m chain=forward layer7-protocol=L7-Torrent \
    src-address=192.168.96.0/24
add action=add-src-to-address-list address-list=Torrent-Add \
    address-list-timeout=2m chain=forward p2p=all-p2p src-address=\
    192.168.96.0/24
add action=add-src-to-address-list address-list=Torrent-Add \
    address-list-timeout=2m chain=forward p2p=bit-torrent src-address=\
    192.168.96.0/24

/ip firewall mangle
add action=mark-connection chain=prerouting comment=Torrent-Conn dst-port=\
    !0-1024,8291,5900,5800,3389,14147,5222,59905 new-connection-mark=\
    Torrent-Conn protocol=tcp src-address-list=Torrent-Add
add action=mark-connection chain=prerouting dst-port=\
    !0-1024,8291,5900,5800,3389,14147,5222,59905 new-connection-mark=\
    Torrent-Conn protocol=udp src-address-list=Torrent-Add
add action=mark-connection chain=prerouting new-connection-mark=Torrent-Conn \
    p2p=all-p2p src-address-list=Torrent-Add
add action=mark-connection chain=prerouting new-connection-mark=Torrent-Conn \
    p2p=bit-torrent src-address-list=Torrent-Add
add action=mark-packet chain=prerouting connection-mark=Torrent-Conn \
    new-packet-mark=Torrent-Conn passthrough=no

Previous
Next Post »

6 comments

Write comments
Ramon Vasquez
AUTHOR
June 18, 2017 at 10:14 AM delete

HI, how to limit their upload speed?

Reply
avatar
Burak BEŞLİ
AUTHOR
October 3, 2017 at 9:17 PM delete

Gog Download Free Torrents Games for pc, mac, linux, ps4, xbox and more game platform. Free Games PC Hack and Cheats come and torrent game download

Reply
avatar
Unknown
AUTHOR
August 9, 2018 at 8:36 PM delete

For all new and existing torrenteers who are on the constant hunt to find a road to safe torrenting – this blog will land them on the right path. A simple solution to all torrenteers problems is a connection to the Best VPN for torrenting. Get yourself a torrent VPN that lets you torrent not only privately, but securely too!

Reply
avatar
October 30, 2018 at 7:51 PM delete

I will try this and update

Reply
avatar
The Blogger
AUTHOR
July 17, 2019 at 6:51 PM delete

On the off chance that you download a pilfered variant, you won't appreciate the endless of updates.https://luckyshiner.com/extratorrent-proxy-mirror-sites-alternatives/

Reply
avatar