139. Mikrotik How to Block Mobile Phone From Accessing the Internet


You can contact me: plus.google.com/+PhallaCCMT; youtube.com/phallaccmt; facebook.com/Phalla.CCMT; twitter.com/PhallaCCMT and Phalla.CCMT@gmail.com

Script:

#DHCP-Server Name
:local DHCPServer "Guest";

#PhallaCCMT.blogspot.com
:foreach i in=[/ip dhcp-server lease find dynamic=yes active-server=$DHCPServer] do={
:local DhcpDynMAC [/ip dhcp-server lease get $i mac-address];
:local DhcpDynCLIENTID [/ip dhcp-server lease get $i active-client-id];
:local DhcpDynHOST [/ip dhcp-server lease get $i host-name];
:local phoneNAME [:pick $DhcpDynHOST 0 4];

#YouCanAddMorePhone
:if ( ($phoneNAME="BLUS") || ($phoneNAME="iPad") || ($phoneNAME="andr") || ($phoneNAME="Andr") || ($phoneNAME="Wind") || ($phoneNAME="iPho") || ($phoneNAME="BLAC") ) do={
/ip dhcp-server lease add block-access=yes mac-address="$DhcpDynMAC" use-src-mac=yes comment="$DhcpDynHOST" server="$DHCPServer" client-id="$DhcpDynCLIENTID";
}
}
/ip dhcp-server lease remove [find host-name~"BLUS*"]
/ip dhcp-server lease remove [find host-name~"android*"]
/ip dhcp-server lease remove [find host-name~"Android*"]
/ip dhcp-server lease remove [find host-name~"Windows*"]
/ip dhcp-server lease remove [find host-name~"iPad*"]
/ip dhcp-server lease remove [find host-name~"iPhone*"]
/ip dhcp-server lease remove [find host-name~"BLACKBERRY*"]

#

Previous
Next Post »

16 comments

Write comments
Unknown
AUTHOR
January 26, 2018 at 8:00 PM delete

Very usefull your script!! Is it possible to place an exception on the script, for i.e: iPhoneManager to be able to access internet? Thank you!

Reply
avatar
Faiza_Hacks
AUTHOR
April 9, 2018 at 11:44 PM delete

I think this is an informative post and it is very useful and knowledgeable. therefore, I would like to thank you for the efforts you have made in writing this article. Blockchain PR

Reply
avatar
August 24, 2018 at 4:03 AM delete

i made some arrangement for don't remove the statics one, so i can release some mobiles


:foreach j in=[/ip dhcp-server lease find dynamic=yes active-server=$DHCPServer] do={
:local DhcpDynHOST [/ip dhcp-server lease get $j host-name];
:local phoneNAME [:pick $DhcpDynHOST 0 4];
:if ( ($phoneNAME="BLUS") || ($phoneNAME="iPad") || ($phoneNAME="andr") || ($phoneNAME="Andr") || ($phoneNAME="Wind") || ($phoneNAME="iPho") || ($phoneNAME="BLAC") || ($phoneNAME="Gala") ) do={
/ip dhcp-server lease remove $j
}
}

Reply
avatar
January 15, 2019 at 10:19 PM delete

This is such a great resource that you are providing and you give it away for free. I love seeing blog that understand the value of providing a quality resource for free. Mobiles under 10000

Reply
avatar
February 5, 2019 at 2:18 PM delete

What a fantabulous post this has been. Never seen this kind of useful post. I am grateful to you and expect more number of posts like these. Thank you very much. www.cbreviewsguru.com

Reply
avatar
saad
AUTHOR
February 9, 2019 at 12:37 AM delete

Please let me know if you’re looking for a article writer for your site. You have some really great posts and I feel I would be a good asset. If you ever want to take some of the load off, I’d absolutely love to write some material for your blog in exchange for a link back to mine. Please send me an email if interested. Thank you! video bokep terbaru

Reply
avatar
William Wyatt
AUTHOR
February 13, 2019 at 9:54 PM delete

Accordingly, the expansion in efficiency and potential procedure re-designing which can be accomplished will positively affect consumer loyalty levels. Android Development Trends 2019

Reply
avatar
WUGI
AUTHOR
February 20, 2019 at 3:44 PM delete

I saw how my friend started earning excellent the casino so I decided to try to play online casino

Reply
avatar
WUGI
AUTHOR
February 20, 2019 at 3:44 PM delete

I saw how my friend started earning excellent the casino so I decided to try to play online casino

Reply
avatar
Charles Jude
AUTHOR
March 6, 2019 at 9:36 PM delete

Truth be told, correspondence over a remote system is a great deal like two-way radio correspondence. internetprivatsphare.de

Reply
avatar
Unknown
AUTHOR
April 5, 2019 at 11:06 AM delete

Great article Lot's of information to Read...Great Man Keep Posting and update to People..Thanks https://impactresearch.org

Reply
avatar
CeLoOwnz
AUTHOR
April 10, 2019 at 10:23 PM delete

How i can limit download on Mobile devices ?

Reply
avatar
aliyan
AUTHOR
June 3, 2019 at 1:22 PM delete

Very informative post! There is a lot of information here that can help any business get started with a successful social networking campaign. reseller hosting en méxico

Reply
avatar
kings
AUTHOR
July 13, 2019 at 5:14 PM delete

Thanks, that was a really cool read!
먹튀

Reply
avatar
Smuglar
AUTHOR
August 14, 2019 at 3:45 PM delete

The script isnt working on my MikroTik... It doesn't run as per schedule and also if i run it manually once the phone is leaves the wifi and connects again it is allowed... I want to add all phones to block list now rather than just blocking them for that session...

Reply
avatar
August 15, 2019 at 3:51 PM delete

Excellent to be visiting your blog again, it has been months for me. Rightly, this article that I've been served for therefore long. I want this article to finish my assignment within the faculty, and it has the same topic together with your article. Thanks for the ton of valuable help, nice share. Voyance par telephone

Reply
avatar