41. Mikrotik Full Bandwidth Management Parent Queue Tree


/ip firewall mangle
add action=mark-connection chain=prerouting dst-address=192.168.2.0/24 in-interface=ether1-WAN new-connection-mark=All-Inconn disabled=no passthrough=yes comment="CONNECTION-IN"
add action=mark-packet chain=prerouting connection-mark=All-Inconn disabled=no new-packet-mark=All-inpkt passthrough=yes comment="UPSTEAM PACKETS"
add action=mark-connection chain=forward in-interface=ether3-LAN new-connection-mark=All-Outconn disabled=no passthrough=yes comment="CONNECTION-OUT"
add action=mark-packet chain=forward connection-mark=All-Outconn new-packet-mark=All-Outpkt disabled=no passthrough=yes comment="DOWNSTEAM-PACKETS"


/ip firewall layer7-protocol
add comment="" name=download regexp="^.*get.+\\.(exe|rar|iso|zip|7zip|flv|mkv|avi|mp4|3gp|rmvb|mp3|img|dat|mov|ipsw).*\$"


/ip firewall layer7-protocol
add comment="" name=streaming regexp="^.*get.+\\.(c.youtube.com|cdn.dailymotion.com|metacafe.com|mccont.com).*\$"


/ip firewall mangle
add action=mark-connection chain=forward comment="phalla" disabled=no dst-address=192.168.2.250 new-connection-mark=phalla-conn passthrough=yes connection-mark=All-Outconn

/ip firewall mangle
add action=mark-packet chain=forward new-packet-mark=phalla-pkt passthrough=yes connection-mark=phalla-conn comment="phalla DOWNSTEAM"


/ip firewall mangle
add chain=forward layer7-protocol=download action=mark-packet new-packet-mark=phalla-dpkt passthrough=no packet-mark=phalla-pkt comment=phalla-Down

/ip firewall mangle
add comment=phalla-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=phalla-spkt passthrough=no packet-mark=phalla-pkt

/ip firewall mangle
add action=mark-packet chain=forward new-packet-mark=phalla-gpkt passthrough=no dst-address=192.168.2.250 packet-mark=gpkt comment=phalla-Game

/ip firewall mangle
add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no packet-mark=phalla-pkt new-packet-mark=phalla-bpkt protocol=tcp comment="phalla BROWSING"


/ip firewall mangle
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=tcp dst-port=5340-5352,6000-6152,10001-10011,14009-14030,18901-18909 comment="Online Game Portal"
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=tcp dst-port=39190,27780,29000,22100,10009,4300,15001,15002,7341,7451
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=tcp dst-port=40000,9300,9400,9700,7342,8005-8010,37466,36567,8822
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=tcp dst-port=47611,16666,20000,5105,29000,18901-18909,9015
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=udp dst-port=27005,27015
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=udp dst-port=27005-27020,13055,7800-7900,12060-12070
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=udp dst-port=8005-8010,9068,1293,1479,9401,9600,30000
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=udp dst-port=14009-14030,42051-42052,40000-40050,13000-13080

/queue tree
add name=phalla parent=All-Bandwidth packet-mark=phalla-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
add name=All-Bandwidth parent=global packet-mark=All-Outpkt queue=default priority=1 max-limit=2M
add name=phalla-Down parent=phalla packet-mark=phalla-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
add name=phalla-Streams parent=phalla packet-mark=phalla-spkt queue=default priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
add name=phalla-Game parent=phalla packet-mark=phalla-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
add name="phalla-Browsing" parent=phalla packet-mark=phalla-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s


Previous
Next Post »

2 comments

Write comments
Unknown
AUTHOR
September 17, 2019 at 11:42 AM delete

Hi1 can i request configuration for gaming priority? Thanks in advance

Reply
avatar