2. Mikrotik Block Torrent Bittorrent uTorrent




Here is a script:

/ip firewall layer7-protocol
add comment="Block Bit Torrent" name=layer7-bittorrent-exp regexp="^(\\x13bitt\
    orrent protocol|azver\\x01\$|get /scrape\\\?info_hash=get /announce\\\?inf\
    o_hash=|get /client/bitcomet/|GET /data\\\?fid=)|d1:ad2:id20:|\\x08'7P\\)[\
    RP]"

/ip firewall filter
add action=add-src-to-address-list address-list=Torrent-Conn \
    address-list-timeout=2m chain=forward layer7-protocol=\
    layer7-bittorrent-exp src-address=10.10.11.0/24 src-address-list=\
    !allow-bit
add action=add-src-to-address-list address-list=Torrent-Conn \
    address-list-timeout=2m chain=forward p2p=all-p2p src-address=\
    10.10.11.0/24 src-address-list=!allow-bit

/ip firewall filter
add action=drop chain=forward dst-port=!0-1024,8291,5900,5800,3389,14147,5222,59905 protocol=tcp \
    src-address-list=Torrent-Conn
add action=drop chain=forward dst-port=!0-1024,8291,5900,5800,3389,14147,5222,59905 protocol=udp \
    src-address-list=Torrent-Conn


Note:
src-address=10.10.11.0/24 : is your Local Address.
- if you have a problem with some application( Skype;Team viewer...) pls add those application port in to

/ip firewall filter
add action=drop chain=forward dst-port=!0-1024,8291,5900,5800,3389,14147,5222,59905,xxxxx protocol=tcp \
    src-address-list=Torrent-Conn
add action=drop chain=forward dst-port=!0-1024,8291,5900,5800,3389,14147,5222,59905,xxxxx protocol=udp \
    src-address-list=Torrent-Conn

Previous
Next Post »

7 comments

Write comments
James harper
AUTHOR
July 10, 2017 at 3:06 PM delete

Torrent clients will be connecting you with many different computers; some of which might not be so friendly. VPN for downloading

Reply
avatar
Laya Bro
AUTHOR
August 3, 2017 at 12:05 AM delete

is it work for routeros v6.3

Reply
avatar
August 23, 2017 at 11:12 PM delete

Hello, i tried using the script but i can still download torrents, Kindly assist

Reply
avatar
Unknown
AUTHOR
June 22, 2018 at 7:19 PM delete

Good but I want to unblock any specific IP for downloading from torrent so what I do ?

Reply
avatar
ahsun haider
AUTHOR
September 23, 2018 at 3:07 AM delete

latest version is not support p2p

Reply
avatar
The Blogger
AUTHOR
July 17, 2019 at 6:51 PM delete

Zygor's guide is in all likelihood not accessible as a deluge document. Regardless of whether there is a Zygor's leveling guide deluge, you won't get the full advantage of the guide and its locale. https://luckyshiner.com/extratorrent-proxy-mirror-sites-alternatives/

Reply
avatar